Legacy Document: This information is historical in nature. Click here to view current site

 

System Requirements

System Requirements for Windows:
Note: We strive for maximum compatability, but can not guarantee operation on any particular system. Please use our free download to make sure the software meets your needs before you purchase. *Note: Some early editions of Windows may not have all the necessary DLLs (e.g. ActiveX or DirectDraw). Windows 95 and 98 are no longer officially supported, but some functions may still work. Click Here for help with updating your system software.

**Note: Windows Vista compabability requires upgrading to version 3.5. Users of 3.4 should read Using iScreensaver with Vista


System Requirements for Macintosh:
Note: We strive for maximum compatability, but can not guarantee operation on any particular system. Please use our free download to make sure the software meets your needs before you purchase. *** Note: Mac OS 8.6 is no longer officially supported, however some functions may still work. Additional software from Apple may be required for using Mac OS 8.6, please see this section for functionality. Mac OS 10.0 is no longer supported by Apple and may not function, however information about 10.0 workarounds can be found here.
Click Here for help with updating your system software.