iScreensaver Logotype
iScreensaver 5.2 has been released, and provides support for macOS High Sierra 10.13. Please read the 10.13 High Sierra Tech Note as well as the Release Notes. macOS 10.14 Mojave is under investigation, and is not yet recommended.

[Solved] Mac OS X users asked to update Quicktime on Sierra

edited September 25 in General Discussions
Here is a quote from a user

"I'm running Mac Sierra. When I double-click the screensaver, a window says:
QuickTime plugin is not installed. QuickTime plugin version 7.6.0 is recommended. But Sierra is longer supporting this if I understand correctly. Can you help me?"

Please advise what my response should be.

Comments

  • What version of iScreensaver Designer is being used?
  • A version of 5, unsure which for this particular one as we make many and then store in cloud.

    Has Quicktime been abandoned or is it normal to have to update it on a Mac? I can't seem to find an answer on Google.
  • Please confirm the version number, as using an old version is most likely the problem. From what you are saying, it actually sounds as if it may be version 4.5?
  • edited December 2016
    Version 5. Definitely not a version 4. Almost certainly the first version 5.
  • Without the specific version number we can't be of much help, I'm afraid. Let us know when you find it.
  • It was actually made with version 4.5.0.388 on 19th December 2015. I think all our others were remade when 5 came out, which was probably just after that.

    I got the Quicktime error too and just pressed Skip and it installed fine. So I think there is no problem, unless Sierra is not letting people skip (I am on El Captian). I'll let you know if he says he can't skip.

    Assume for now that all is OK.

    Thank you for your quick responses.
  • That makes sense, and won't happen in version 5.

    Please note that we've just released a new version with better 10.12 Sierra support, release 5.0.3.1128 available here: http://iscreensaver.com/download

    We encourage you to check it out and start using version 5 if possible.
Sign In or Register to comment.