iScreensaver
iScreensaver has been updated to version 6.0.4.1291

Release Notes
We are pleased to announce the release of iScreensaver version 6 which supports macOS 10.11 through 10.14 and Windows 7 through 10. Read about Version 6

[Solved] Screensaver.exe encountered an error: File not found: install_flags

edited September 2018 in General Discussions
I'm using the unregistered on a mac.
I'm trying to do a screensaver for a client on PC — if they approve, the full version will be purchased.
Seems to work fine on mac but the client has just come back and said they get the following error on launching the exe --> Screensaver.exe encountered an error: File not found: install_flags

Any help would be appreciated

Comments

  • This sounds like you may have sent them the wrong file? Be sure that when you are creating a single-file-EXE installer that you send them the correct file.

    If you are sure you are sending the correct file, then let us know as it could be something else.
  • Hi,

    Thanks for quick response. The client requires PC and mac so I did 'Build All' and sent them the lot. I have since gone back and created a single-file-EXE and tested it on the PC we have in the office – I get the same error (file not found: install_flags)

  • Please do this:
    * Make sure you are using the latest version (4.5.0.388 as of today).
    * On the Build Tab, click the "Reveal" button to show the Installers folder. Delete everything inside the Installers folder.
    * Quit iScreensaver
    * ReOpen iScreensaver
    * open your project, go to the Build tab, and click on the Win tab.
    * make sure the "Make Single File EXE" button is checked. Leave the ZIP button un-checked.
    * Click the "Build Win" button
    * Click the "Details" button and scan all of the Log messages : do you get any warnings or errors? If so, fix them before continuing.

    If the build is successful, click the Reveal button. There should be a single EXE file shown in the Finder. That is the file that you should deliver to the client.

    If that file is not working, then please email us with a URL to download a copy, and we can run some tests here.
  • Thanks for this but still not working — I have sent an email
  • (customer provided us a URL to download their sample).
    Thank you.

    This is very weird, we've never seen this before. What appears to be happening is that as you are doing the build, 3 critical files are not being included in the build, and as a result, the installer does not work.

    More questions:
    * What version of Mac OS X are you using?
    * Are you running any antivirus software on the Mac?
    * Please create a brand new iScreensaver project and add a single image file to it. Build that as a single-file-EXE for windows and test it on a PC. Does that one work?

  • Hi,

    Answers
    * latest version of OS X (10.9)
    * no anti virus software installed
    * will carry out test and update you shortly
  • Further to last post

    *Single image file works on PC

    Other info:
    When using multiple images I used 12 x 800kb each
    Single image was 1 x 200kb


  • Interesting. My hunch is that you may have an illegal filename somewhere in your project. Would you please email us again so we can download your project file (the .isc file) as well as your image files, so we can do more tests?
  • Update: it turns out that the author was building the screensaver on Mac OS X 10.9, and was storing the project files, artwork, and doing the screensaver build all on a SMB network drive. Apparently this causes problems under 10.9 (there are other reports of 10.9 having SMB issues).

    The solution was quite simple: move all files to a local hard drive on the Mac, then re-build.

    The author reports that this fixes the problems entirely.
Sign In or Register to comment.